Links aus dem Forum heraus

Ihr habt Wünsche, Kritik oder eine Anregung für uns? Nur her damit
Beobachter: wintstar

Links aus dem Forum heraus

Beitragvon wintstar » Mo 2. Feb 2015, 11:19

http://area52.wintstar.de/phpBB/viewtop ... 1714#p1714

Irgendwie scheint das mit den externen Links nicht richtig zu funktionieren. Oberer Link geht direkt zum Beitrag, es erscheint aber nur das Thema.
Gruß wintstar :)

Zitat: "Damit das Mögliche entsteht, muss immer wieder das Unmögliche versucht werden" (Hermann Hesse (1877-1962)).

phpBB 3.0.14 und phpBB 3.1.9 diese Versionen unter PHP 7
Benutzeravatar
wintstar
Registriertes Mitglied
Beiträge: 262
Themen: 19
Registriert: 01.11.2013
Danke gegeben: 13
Danke bekommen:
24 mal in 21 Beiträgen

Links aus dem Forum heraus

Beitragvon regazer » Di 3. Feb 2015, 12:18

Anscheinend wurde jetzt stillschweigend vorerst doch wieder die direkte Weiterleitung ermöglicht, vermutlich um Schwachstellen im Weiterleitungscode zu suchen und zu beheben.

Danke !

Viel Glück beim Überprüfen des Codes.
The more I look at the sources of phpBB the less I like it. :evil:
regazer
Registriertes Mitglied
Beiträge: 129
Themen: 10
Registriert: 09.08.2013
Danke gegeben: 8
Danke bekommen:
3 mal in 3 Beiträgen

Links aus dem Forum heraus

Beitragvon Nashra » Mi 4. Feb 2015, 10:19

regazer hat am Di 3. Feb 2015, 12:18 geschrieben:Anscheinend wurde jetzt stillschweigend vorerst doch wieder die direkte Weiterleitung ermöglicht

Aus Zeitmangel meinerseits erstmal einfach deaktiviert.

regazer hat am Di 3. Feb 2015, 12:18 geschrieben:vermutlich um Schwachstellen im Weiterleitungscode zu suchen und zu beheben.

Das Teil war/ist Beta, wo der Fehler liegt ist bekannt, aber trotz einiger Veränderungen
will es nicht so recht. Es gibt leider Dinge die laufen nie 100% und da ich im Moment wenig Zeit
habe, bleibt es erstmal aus.
Nashra
Kein Support per PN/E-Mail usw.
Allround-phpBB.de
Benutzeravatar
Nashra
Administrator
Beiträge: 1319
Themen: 163
Registriert: 11.10.2012
Wohnort: Wankum
Danke gegeben: 13
Danke bekommen:
115 mal in 93 Beiträgen
Vorname: Ralf
phpBB.de: FRvN
phpBB.com: Nashra

Links aus dem Forum heraus

Beitragvon wintstar » Mi 4. Feb 2015, 10:42

Nashra hat am Mi 4. Feb 2015, 10:19 geschrieben:...
Das Teil war/ist Beta, wo der Fehler liegt ist bekannt, aber trotz einiger Veränderungen
will es nicht so recht. Es gibt leider Dinge die laufen nie 100% und da ich im Moment wenig Zeit
habe, bleibt es erstmal aus.


Das was nie 100% funktioniert, liegt/könnte an unterschiedlichen Servereinstellungen liegen. Und die müssten eigentlich nach EU-Recht einheitlich sein, oder? Oder nicht :lol: :lol: :lol:
Gruß wintstar :)

Zitat: "Damit das Mögliche entsteht, muss immer wieder das Unmögliche versucht werden" (Hermann Hesse (1877-1962)).

phpBB 3.0.14 und phpBB 3.1.9 diese Versionen unter PHP 7
Benutzeravatar
wintstar
Registriertes Mitglied
Beiträge: 262
Themen: 19
Registriert: 01.11.2013
Danke gegeben: 13
Danke bekommen:
24 mal in 21 Beiträgen

Links aus dem Forum heraus

Beitragvon regazer » Mi 4. Feb 2015, 12:58

@wintstar:
Manches liegt auch am Browser. Gerade habe ich ca. 4 Stunden damit verbracht, ein HTML-/CSS-Design so anzupassen, daß es sich mit IE und FF wenigstens im Wesentlichen ähnelt, obwohl es dem IE natürlich wieder an diversen Funktionalitäten mangelt, die dann damit eben nicht nutzbar sind.

@Nashra:
Gibt es irgendwo den Source? :roll: Da ich meist viel Geduld habe ... würde ich mir den gerne mal ansehen.

Vielleicht finde ich was.
The more I look at the sources of phpBB the less I like it. :evil:
regazer
Registriertes Mitglied
Beiträge: 129
Themen: 10
Registriert: 09.08.2013
Danke gegeben: 8
Danke bekommen:
3 mal in 3 Beiträgen

Links aus dem Forum heraus

Beitragvon Nashra » Do 5. Feb 2015, 11:21

regazer hat am Mi 4. Feb 2015, 12:58 geschrieben:@Nashra:
Gibt es irgendwo den Source? :roll: Da ich meist viel Geduld habe ... würde ich mir den gerne mal ansehen.

Vielleicht finde ich was.

siehe hier: Links aus dem Forum heraus
Nashra
Kein Support per PN/E-Mail usw.
Allround-phpBB.de
Benutzeravatar
Nashra
Administrator
Beiträge: 1319
Themen: 163
Registriert: 11.10.2012
Wohnort: Wankum
Danke gegeben: 13
Danke bekommen:
115 mal in 93 Beiträgen
Vorname: Ralf
phpBB.de: FRvN
phpBB.com: Nashra

Links aus dem Forum heraus

Beitragvon regazer » Fr 6. Feb 2015, 02:34

Sorry, Nashra, aber wenn ich dieses Zeug (auf das Dein Link verweist) einfach nur kopiere (also genau das mache, was die "install.xml" beschreibt) tut sich danach ... NICHTS !

Wenn es aber nichts wirklich zu installieren gibt: Wie soll das dann überhaupt gestartet werden können ? Wo und wie soll denn diese "go_body.html" - Datei im Template bzw. die "go.php" im Root je aufgerufen werden ?

Beim Versuch, die "go.php" im Root manuell aufzurufen, gibt es einen Error 404 (Objekt nicht gefunden) ...

Kann mir mal bitte jemand erklären, WIE man das überhaupt in Gang setzen soll ? Habe ich irgendwo irgendwas übersehen ? :roll:

Ist das was Ihr hier eingesetzt hattet, wirklich das Teil aus dem Link ? :roll:
Wenn ja: Wie wurde es eingebunden ?

Oder läuft das nicht auf localhost ? Dann wäre die Fehlersuche allerdings extrem schwierig.
The more I look at the sources of phpBB the less I like it. :evil:
regazer
Registriertes Mitglied
Beiträge: 129
Themen: 10
Registriert: 09.08.2013
Danke gegeben: 8
Danke bekommen:
3 mal in 3 Beiträgen

Links aus dem Forum heraus

Beitragvon Nashra » Fr 6. Feb 2015, 09:55

Das ist ein Addon für die Mod Prime_Links d.h. die Mod Prime_Links muß
installiert sein und in der includes/prime_links.php wird es dann eingetragen.
Code: Alles auswählen
   define('EXTERNAL_LINK_PREFIX', 'http://www.allround-phpbb.de/go.php?');

Steht aber auch alles auf der Seite bei Stoker ;)
http://www.phpbb3bbcodes.com/viewtopic. ... Page+Addon
Nashra
Kein Support per PN/E-Mail usw.
Allround-phpBB.de
Benutzeravatar
Nashra
Administrator
Beiträge: 1319
Themen: 163
Registriert: 11.10.2012
Wohnort: Wankum
Danke gegeben: 13
Danke bekommen:
115 mal in 93 Beiträgen
Vorname: Ralf
phpBB.de: FRvN
phpBB.com: Nashra

Links aus dem Forum heraus

Beitragvon regazer » Fr 6. Feb 2015, 15:44

Naja, da steht eigentlich Optional (but highly recommended): Prime Links MOD.
Darum ging ich davon aus, das wäre nicht unbedingt erforderlich. Unter Option verstehe ich ein KANN aber kein MUSS.

Aber o.k. - Danke für den Hinweis.

Edit 1 (Stunden später) :
Ich habe mir das jetzt mal näher angesehen.

Requirements:
Error Pages MOD by Stoker (duh!)


DAS ist Bedingung, nicht Prime Links.

Prime Links selbst funktioniert doch soweit, aber der einzige Sinn besteht m.E. im hübschen, animierten Symbol, das auf externe Links hinweist. Nötig ist solch Schnickschnack aber nicht.

Es geht ja hier um den Hinweis auf die Weiterleitung usw., also um dieses "Error Pages External Redirect Link Page Addon" ...

Wie gehabt kann ich es (nach Einbau auch aller umständlich bei Prime Links beschriebenen Zusätze) gar nicht erst starten. Ich bekomme immer die Fehlermeldungen der eigentlichen "Error Pages" wie
403 Forbidden
Hello admin
You don't have permission to access the requested directory.

( Ich habe das noch nicht eingedeutscht. )

Erst dachte ich, es läge am neuen, aufgeblähten Format der .htaccess-Datei des phpBB 3.0.13, aber das ist es nicht.

Edit 2:
o.k., wenn man in go.php die Bedingung if ((!isset($referrer) || ($referrer != $our_referrer))) deaktiviert, kommt endlich der Weiterleitungstext und der Rest.

Ich werde mich bemühen ... und melde mich dann wieder.

Edit 3: ( go_body-html )
Negative Zählwerte gibt es nur, wenn der Zugriff auf die Zielseite deshalb länger dauert, weil die Verbindung schlecht ist. Optisch läßt sich das aber durch eine Darstellungssperre für negative Werte beheben:
Code: Alles auswählen
   function gett(id){
        if (time <0) {return} else {
      //if (time <  10) {time =  '0' + time};

      if (document.getElementById) return document.getElementById(id);
      if (document.all) return document.all.id;
      if (document.layers) return document.layers.id;
      if (window.opera) return window.opera.id;
      }
   }
Ansonsten habe ich diese Fehler in "go.php" feststellen können, ohne die Ursachen zu kennen:
Code: Alles auswählen
   $referrer = $matches[0];   // Undefined offset: 0
   $our_referrer = $our_matches[0]; // Undefined offset: 0
   $redir_url = (($url == $_SERVER['SCRIPT_URI']) ? $our_redir_url : urlencode($url)); // Undefined index: SCRIPT_URI
Für unvollständige Weiterleitungen scheint mir (ich kann mich auch täuschen) das fehlende "SCRIPT_URI" verantwortlich zu sein.

Eine Auflistung der verfügbaren Werte bekommt man, wenn man am Schluß von "go.php" die Anweisung page_footer(); temporär (nur zum Testen !!!) durch
Code: Alles auswählen
// formatierte Testausgabe :
echo '<pre>';
print_r($_SERVER);
echo '</pre>';
//page_footer();
ersetzt. Dabei zeigt sich, daß die entscheidenden Werte bei [QUERY_STRING] und [REQUEST_URI] alles ab dem Zeichen # (inklusive dieses Zeichens) nicht mehr enthalten. So wird dann z.B. aus http://www.allround-phpbb.de/viewtopic.php?f=24&p=6189&sid=a9c1bd4d562cdc7cbd5d1053087edbd5#p6189 nur noch ein http://www.allround-phpbb.de/viewtopic.php?f=24&p=6189&sid=a9c1bd4d562cdc7cbd5d1053087edbd5 und vielleicht würde "SCRIPT_URI" den vollständigen Pfad liefern.
The more I look at the sources of phpBB the less I like it. :evil:
regazer
Registriertes Mitglied
Beiträge: 129
Themen: 10
Registriert: 09.08.2013
Danke gegeben: 8
Danke bekommen:
3 mal in 3 Beiträgen

Alternative ?

Beitragvon regazer » Sa 7. Feb 2015, 23:09

Gerade fand ich bei Webmasterpro diese interessante Möglichkeit:

Code: Alles auswählen
<a href="http://www.webmasterpro.de/" onclick="return window.confirm('Link folgen?');">Abfrage</a>


Vielleicht läßt sich diese Abfrage (mit entsprechend angepaßtem Text) anstelle des verzögerten Weiterleitens irgendwie passend reinbasteln. :roll:
The more I look at the sources of phpBB the less I like it. :evil:
regazer
Registriertes Mitglied
Beiträge: 129
Themen: 10
Registriert: 09.08.2013
Danke gegeben: 8
Danke bekommen:
3 mal in 3 Beiträgen

VorherigeNächste

Zurück zu Kritik / Anregungen / Wünsche / Lob



Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast


x-Achse: 0
y-Achse: 0
cron