[ERLEDIGT] Call to a member function set_template()....

Hier könnt ihr Fragen im Allgemeinen zu phpBB stellen und Support erhalten
Hinweis für Supportanfragen!

1. Alle Codes wie z.B. index.php, overall_header.html usw. bitte ins Pastebin und dann im Beitrag verlinken
(kleinere Code-Snippets sind hiervon ausgenommen und sollten via "Code" eingefügt werden)
2. Name der MOD um die es geht und die URL zum Download
3. URL zum eigenen Forum
4. Wurde eine "Anfrage" gemacht und eine Lösung gefunden, den Thread bitte auf "Erledigt" stellen.
Beobachter: Sarah

[ERLEDIGT] Call to a member function set_template()....

Beitragvon Sarah » Mo 14. Jul 2014, 15:37

Moin zusammen,

jetzt möchte ich Euch mal aus dem Sommerloch helfen, die Fussi - WM haben wir ja jetzt nun auch bestens überlebt :D :D :D

Auch auf die Gefahr hin, dass das Thema hier vielleicht schon behandelt wurde, ich habe zu meinem Problem nichts gefunden.

Ausgangssituation:

Ich hatte ein komplettes Backup (ftp und mysql) meines Forums erstellt und das lokal (XAMPP) installiert. Dieses läuft auch lokal wunderbar prima, hab mir dieses für eine Testumgebung "zurechtgestutzt" (alle User außer mich und mein Team gelöscht, samt Beiträge) und wollte das danach auf meinem Server hochladen und es anschließend starten. Aber da bekomme ich nur diese seltsame Fehlermeldung:

Fatal error: Class 'template' not found in /www/htdocs/w010712f/common.php on line 108

Also ich nochmal alles überprüft (config.php und CHMOD nach dieser >>> Anleitung ) aber nix. Ich hab denn mal die angemeckerte Zeile testweise auskommentiert und bekomme dadurch nur noch weitere Fehlermeldungen.

Das ist der Link zu meinem >>> Testforum , und wie gesagt, lokal läuft das Forum anstandslos. Hat jemand vielleicht eine Idee, was das sein könnte?

Danke im voraus :)


lg

-S
Benutzeravatar
Sarah
Registriertes Mitglied
Beiträge: 203
Themen: 29
Registriert: 22.10.2012
Wohnort: Hamburg
Danke gegeben: 21
Danke bekommen:
8 mal in 5 Beiträgen
Vorname: Sarah
phpBB.de: SarahUV
Beitrag wurde zuletzt geändert von Sarah am Mo 14. Jul 2014, 19:53, insgesamt 1-mal geändert.

Call to a member function set_template()....

Beitragvon Kirk » Mo 14. Jul 2014, 18:12

Hi Sarah
Öffne mal deine root/common.php und schau ob dies bei dir drin steht (Notepad ++ Zeile 91):
Code: Alles auswählen
require($phpbb_root_path 'includes/template.' $phpEx); 

Wenn ich bei meinem Tesboard dieses lösche, erhalte ich die selbe Fehlermeldung wie bei dir.
Benutzeravatar
Kirk
Registriertes Mitglied
Beiträge: 178
Themen: 20
Registriert: 10.11.2013
Wohnort: Wunsiedel
Danke gegeben: 0
Danke bekommen:
24 mal in 24 Beiträgen
Vorname: Udo
phpBB.de: Kirk

Call to a member function set_template()....

Beitragvon Sarah » Mo 14. Jul 2014, 18:23

Hi Kirk,

vielen Dank für Deine schnelle Antwort.

Aber daran scheint es nicht zu liegen, diese Zeile ist exakt so vorhanden.


lg

-S
Benutzeravatar
Sarah
Registriertes Mitglied
Beiträge: 203
Themen: 29
Registriert: 22.10.2012
Wohnort: Hamburg
Danke gegeben: 21
Danke bekommen:
8 mal in 5 Beiträgen
Vorname: Sarah
phpBB.de: SarahUV

Call to a member function set_template()....

Beitragvon Kirk » Mo 14. Jul 2014, 18:27

Dann schau ob im Ordner root/includes eine Datei Namens template.php vorhanden ist.
Benutzeravatar
Kirk
Registriertes Mitglied
Beiträge: 178
Themen: 20
Registriert: 10.11.2013
Wohnort: Wunsiedel
Danke gegeben: 0
Danke bekommen:
24 mal in 24 Beiträgen
Vorname: Udo
phpBB.de: Kirk

Call to a member function set_template()....

Beitragvon Sarah » Mo 14. Jul 2014, 18:33

ja, ist vorhanden, aber hatte eine Größe von 0 Byte, habe ich also dann neu hoch geladen, jetzt hab ich eine neue Fehlermeldung. Vielen Dank für den Lösungsansatz, ich glaub, ich sollte alles noch mal neu hoch laden **ggrrr :roll:

Nochmals danke :)
Benutzeravatar
Sarah
Registriertes Mitglied
Beiträge: 203
Themen: 29
Registriert: 22.10.2012
Wohnort: Hamburg
Danke gegeben: 21
Danke bekommen:
8 mal in 5 Beiträgen
Vorname: Sarah
phpBB.de: SarahUV

Call to a member function set_template()....

Beitragvon Kirk » Mo 14. Jul 2014, 19:29

Währe es nicht einfacher ein komplett neues Testboard zu erstellen?
Benutzeravatar
Kirk
Registriertes Mitglied
Beiträge: 178
Themen: 20
Registriert: 10.11.2013
Wohnort: Wunsiedel
Danke gegeben: 0
Danke bekommen:
24 mal in 24 Beiträgen
Vorname: Udo
phpBB.de: Kirk

Call to a member function set_template()....

Beitragvon Sarah » Mo 14. Jul 2014, 19:53

ganz einfach, ich wollte (wieder) ein Testforum mit allen Mods, die ich auch produkiv im Einsatz habe. Mit demselben Style dazu. Ich hätte alles von vorn anfangen müssen, das hätte Tage gedauert.

Und nu geht es :D


lg

-S
Benutzeravatar
Sarah
Registriertes Mitglied
Beiträge: 203
Themen: 29
Registriert: 22.10.2012
Wohnort: Hamburg
Danke gegeben: 21
Danke bekommen:
8 mal in 5 Beiträgen
Vorname: Sarah
phpBB.de: SarahUV

Call to a member function set_template()....

Beitragvon Kirk » Di 15. Jul 2014, 18:35

Was war denn jetzt die Ursache?
Benutzeravatar
Kirk
Registriertes Mitglied
Beiträge: 178
Themen: 20
Registriert: 10.11.2013
Wohnort: Wunsiedel
Danke gegeben: 0
Danke bekommen:
24 mal in 24 Beiträgen
Vorname: Udo
phpBB.de: Kirk

Call to a member function set_template()....

Beitragvon Sarah » Di 15. Jul 2014, 18:54

ich habe FileZilla verwendet und es wurden einige Dateien (insbesondere html und php Dateien) nicht vollständig hoch geladen, sprich, diese waren einfach leer (0 byte).

Mit der Firefox-Erweiterung FireFTP hat es dann ohne Probleme geklappt


lg

-S
Benutzeravatar
Sarah
Registriertes Mitglied
Beiträge: 203
Themen: 29
Registriert: 22.10.2012
Wohnort: Hamburg
Danke gegeben: 21
Danke bekommen:
8 mal in 5 Beiträgen
Vorname: Sarah
phpBB.de: SarahUV


Zurück zu Fragen / Support



Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast


x-Achse: 0
y-Achse: 0
cron